2006-04-11

Pagerインストールでエラー

Pagerをインストールしようとすると、以下のエラーが出る。
downloading Pager-2.3.6.tgz ...
Starting to download Pager-2.3.6.tgz (26,964 bytes)
.........done: 26,964 bytes
ERROR: pear.php.net/Pager: conflicting files found:
Pager\Sliding.php (pear.php.net/pager_sliding)
これは、Pager_Slidingのファイルが既に存在して競合しているため。
Pager_Slidingの機能は既にPagerに取り込まれているため、現在Pager_Slidingは非推奨となっている。

コマンドで
pear uninstall Pager_Sliding

としてPager_Slidingをアンインストールし、
pear install Pager

でPagerをインストールして解決。

参照:
PEAR :: Manual :: Pager (v.1.x) 対 Pager_Sliding
コメントを投稿