2012-04-29

Oracle DB作成時にORA-01503とORA-01158

Oracle 10gR2でこんなエラーが出てDBCAでデータベースができん!
ORA-01503: CREATE CONTROLFILE???????
ORA-01158: ?????????????????????????????
とおもったら、グローバルデータベース名とSIDに8文字以上を指定してました... orz すんません

osakana というDBがすでにあって osakana2 を作ろうとしました。
DBCAさんは気を利かせて、グローバルデータベース名のosakana2を1文字消してosakanaに!
(たぶんSIDはそのまま)

そしてエラーが発生><!

DBCAで「グローバルデータベース名は8文字までです」とか警告だしてよ!

おそらくは
ORA-01503: CREATE CONTROLFILE???????
ORA-01158: ?????????????????????????????
のところは
ORA-01503: CREATE CONTROLFILEでエラーが発生しました
ORA-01158: データベースosakanaはすでにマウントされています
だったんじゃないかなあと。

皆様お気を付けくださいませ。

2012-04-18

ApacheでSPDY

ApacheでSPDYプロトコルが使えるようになったそうです。ステキですね。

Add SPDY support to your Apache server with mod_spdy - Google Developers Blog
http://googledevelopers.blogspot.jp/2012/04/add-spdy-support-to-your-apache-server.html

mod_spdy - mod_spdy — Google Developers
http://developers.google.com/speed/spdy/mod_spdy/
Apache2.2以上対応、mod_sslが必須です。
Debian, Ubuntu, Fedora, CentOS などが対応OSです。

SPDYについては下記を読んでみてください。

2012年3月28日 速度向上とモバイル対応を目指したHTTP 2.0のプロポーザル、マイクロソフトがIETFに提出。SPDYとWebSocketが起点に - Publickey
http://www.publickey1.jp/blog/12/http_20ietfspdywebsocket.html

2009年11月13日 Google、HTTPを補う高速化プロトコル「SPDY」発表 - ITmedia ニュース
http://www.itmedia.co.jp/news/articles/0911/13/news019.html

SPDY - SPDY — Google Developers
https://developers.google.com/speed/spdy/

今のところ対応ブラウザはChromeです。
Chromeの起動オプションに
--use-spdy=npn
と追加して起動するとSPDYを使えるそうです。

なお、Firefoxも11で対応しています。
有効化するには、
about:confignetwork.http.spdy.enabled の値を true にしてください。

自分でApache持ってないよ!という人はChromeに上のオプションを付けて起動したうえでTwitterを見ると速いかもしれません!

Twitter、Google提案のSPDYプロトコルを導入 | ネット | マイナビニュース
http://news.mynavi.jp/news/2012/03/14/025/

追記:
あ、検証サイトがあった。
https://www.modspdy.com/world-flags/